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Chapter 9:

CAD Tutorial

In this tutorial you’ll learn about:
•      CAD Detail Windows
•      Exploding and Modifying a CAD Block
•      Creating a New CAD Block

•      CAD Detail from View
•      Creating a Plot Plan

CAD Detail Windows
CAD Details are special view windows for drawing, saving, and organizing any 2D drawings 
associated with the current plan, such as section details, plot plans, and schedules. Like other 
views, CAD Details are saved with the plan or layout they are created in and can be printed. If 
a CAD Detail is created in a plan file, it can also be sent to layout at a specified scale. See 
“Sending Views to Layout” on page 1222 of the Reference Manual.

To create a new CAD Detail window

1. Select CAD> CAD Detail Management  to open the CAD Detail Management dialog. 
An alphabetical list of all CAD Details saved with the current plan displays on the left side 
of the dialog.

2. Click New to open the Create New CAD Detail dialog.
3. Type a short, descriptive name for the CAD Detail, such as "Foundation & Wall Detail" 

then click OK to open a new, blank CAD Detail window.
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Your new CAD Detail window is ready for you to add CAD objects, text, dimension lines, 
schedules, and more.

Exploding and Modifying a CAD Block
CAD Detail windows are an excellent place for you to draw and organize your detail drawings.  
Drawings like foundation details can be created from scratch using the CAD Tools, but you can 
also save time by choosing a CAD block from the library, placing it into a CAD Detail window, 
and then modifying it to suit your needs.

A CAD block simply is a group of 2D CAD objects, text objects, and/or other CAD blocks that 
have been grouped together so that they behave as a single object when selected.

To place a CAD block from the Library Browser

1. Select View> Library Browser  and either search or browse to locate a CAD block.
• For this tutorial, the "Basement Foundation: Finished 4" CAD block from the CAD 

Blocks and Details Bonus Catalog is used. For information about obtaining Bonus 
libraries, see “Downloading Library Content” on page 819 of the Reference Manual.

2. Select the CAD block in the library and then click in the CAD Detail window to place it at 
that location.

A selection of CAD Details is available in the Chief Architect Core
Catalogs, however, additional CAD Details can also be downloaded

from the website.
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As with other objects, CAD blocks can be selected and edited. A few of the available editing 
methods are described in this tutorial, and more information can be located in “Editing 
Objects” on page 101 of the Reference Manual. 

Reflecting a CAD Drawing
Like other objects, CAD blocks can be reflected. 

To reflect a CAD drawing

1. Select CAD> Line> Draw Line , then create a vertical line to the right of the CAD 
block.

2. Next, using the Select Objects  tool, click to select the CAD block.

3. Click on the Reflect About Object  edit tool, then click on the CAD line that you just 
placed to reflect the CAD block over to the other side of the line. 

Exploding a CAD Block
If you click on a CAD block, you will notice that the entire CAD block is selected. This allows 
you to easily move, rotate, reflect, or copy and paste the entire object; but it also means that you 
cannot select its individual elements unless you explode the CAD block.

To explode a CAD block

1. Using the Select Objects  tool, click to select the CAD block.

2. Next, click on the Explode CAD Block  edit button to explode the CAD block into its 
separate elements. 
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Editing the Elements of an Exploded Block
If you click on a CAD block that has been exploded, it will no longer behave like a single 
object. Instead, each of its elements can be modified independent of the others.

To move an edge of a closed polyline using dimensions

1. Zoom  in on the lower portion of the CAD Detail, and using the Select Objects  
tool, click on the right side of the lower Concrete filled polyline.

2. Notice that the blue CAD line is selected first. We can Delete  that blue CAD line, and 
again select the right side of the closed polyline.

3. Move your mouse over the Temporary Dimension of 7 5/8". When the pointer turns in to a 
hand, click to activate the Move Objects Using Dimensions in-line text box. Type in an 
exact value of 8" and press Enter on the keyboard to apply this change.

4. Repeat this process on the upper closed polyline with the Concrete Fill Style applied so 
that both are 8".

Once the rectangular closed polylines with the Concrete Fill Style have been resized, they 
overlap other polylines.

To display an object behind all other objects
1. Select the upper right closed polyline that is overlapping, and click on the Open 

Object  edit tool.
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2. On the Line Style panel of the Polyline Specification dialog, in the Drawing Group 
selection, move the radio button to Back Group and click OK.

Creating a New CAD Block
A CAD block can be created from any collection of CAD objects, text, or other CAD blocks - 
including those that originally came from a CAD block that was exploded. CAD blocks can 
also be added to the library for future use.

Specifying an Insertion Point
By default, a CAD block will have a placement snap point, referred to as its Insertion Point, at 
its center. You can specify a custom Insertion Point to make it easy to place the drawing with 
precision using a particular feature as a reference instead of its center point.

To specify insertion point locations

1. Select Edit> Snap Settings and make sure that all Object Snaps  are enabled. See 
“Object Snaps” on page 162 of the Reference Manual.

2. Select CAD> Points> Place Point  then click on the top right corner of the rectangular 
polyline representing the concrete footing to place a point at that location.
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3. Place a second CAD Point  at the upper portion at the top right corner of the polyline 
representing the concrete stem wall. For more information, see “Select Insertion Point” on 
page 1091 of the Reference Manual.

Blocking and Adding the Library
Once a CAD drawing has everything it requires to meet your needs, you can block it; and, if the 
drawing is one that you can use for other projects, you can add it to the library for future use.

Here, we will create a CAD block composed of two nested blocks with custom insertion points.

To create a CAD block and add it to the library
1. First, let’s set up our Preferences so it is easy to select two portions of our CAD drawing 

separately. Select Edit> Preferences ,and choose the Edit panel. 
• Under Marquee Selection, click the radio button beside Select Contained Objects, 

then click OK. See “Edit Panel” on page 109 of the Reference Manual.

2. Select Window> Fill Window .

3. Using the Select Objects  tool, click and drag a marquee around the lower section of 
the detail drawing.

4. Click the Make CAD Block  edit button to block all of the selected text, lines, and 
polylines in to a single CAD block.

5. With the CAD block selected:

• Click the Select Insertion Point  edit button.
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• Move your mouse pointer over the top right corner of the concrete footing and when 
you see the Endpoint snap indicator, click once.

• The CAD block’s Move edit handle will now display at the location of its custom 
Insertion Point.

6. Repeat this process with the upper portion of the drawing.

7. Now, group select both upper and lower CAD blocks and use Make CAD Block  edit 
tool to block them together, forming a single CAD block composed of two nested blocks.

8. Finally, click the Add to Library  edit tool to add it to the User Catalog in the library. 
You can then rename it and move it in to a folder to suit your organizational style. See 
“Adding Library Content” on page 821 of the Reference Manual. 

CAD Detail from View
CAD Detail from View is a powerful feature that converts the current line-based view into a 2D 
CAD drawing located in its own CAD Detail window. This drawing is composed of CAD lines, 
arcs, and polylines that you can edit, and is no longer dynamically linked to the model. For 
more information, see “CAD Detail from View” on page 1098 of the Reference Manual.

To create a CAD Detail from View
1. In floor plan view, select 3D> Create Orthographic View> Backclipped Cross 

Section , then click and drag a camera arrow within the interior of the structure. 
• Keep in mind that this type of view will only include objects or portions of objects 

located between the starting and stopping points of the camera’s Line of Sight. 
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• For more information, see “Cross Section/Elevation Camera Tools” on page 894 of the 
Reference Manual.

2. Select Tools> Layer Settings> Display Options , and turn off the display of any layers 
that you do not need for the purposes of a foundation wall detail, such as all fixtures, 
furnishings, and cabinets, then click OK.

3. Zoom in on the right corner of the basement.

4. Next, select CAD> CAD Detail from View  to convert the current view in to a 2D 
CAD drawing in a new CAD Detail window. 

5. The new CAD Detail window will become the active view and you can edit it to suit your 
needs. For more information, see “CAD Details” on page 1097 of the Reference Manual

Adding and Positioning a CAD Block
Now we are ready to insert the modified foundation CAD Block into the CAD Detail and 
precisely position it. 

To add and position the CAD block

1. Zoom  in on the CAD Detail that represents the lower right portion of the foundation 
wall.

2. Next, in the Library Browser, browse to your custom modified CAD Block, select it, and 
click in the view to place it.

3. Select the CAD Block and click on the Explode CAD Block  edit tool.
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4. Select the lower CAD Block and use its end handles to move it until it snaps into position 
over the CAD lines representing the footing in the larger drawing.

5. You can also use the Point to Point Move  edit tool to do this. First, click on the CAD 
block’s Insertion Point, then click on the top right corner of the CAD lines representing the 
footing in the larger drawing. For more information, see “Point to Point Move” on page 
221 of the Reference Manual.

6. Repeat this process to place the upper CAD block.
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7. The Layout Tutorial discusses how to send views such as this one to layout, so make sure 

to Save  your plan.

Creating a Plot Plan
A plot plan is essentially a map of a property’s legal description. Plot plans usually have a 
North Pointer and can also include other features such as the location of buildings and setback 
lines.

When a property’s shape is more complicated than a basic rectangle, you may find it easiest to 
draw the plot lines yourself, rather than try to edit the terrain perimeter to meet your needs.

A plot plan can be drawn in floor plan view or, if you prefer, in a CAD Detail. See “CAD Detail 
Windows” on page 179.

To create a CAD Detail for the plot plan
1. If you want to draw your plot plan in a CAD Detail, select CAD> CAD Detail 

Management  and click New.
2. Type a short, descriptive name for your detail, such as "Plot Plan" and click OK.

3. Select Tools> Default Settings , and in the Default Settings dialog, double-click on 
"Active Defaults" in the tree list.
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4. In the Active Defaults dialog:

• Select "Plot Plan Annotations" from the Currently Using drop-down list.
• Notice the changes to the Current Active Defaults settings. They now set to use 

defaults designed for drawing plot plans.
• Click OK to close the dialog and apply these changes to the current view.

5. When to the CAD Detail window, notice that Plot Plan Annotations is selected in the 
Active Annotation Set Control in the toolbars. For more information, see “Annotation 
Sets” on page 78.
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To create a plot plan polyline

1. Select CAD> Points> Input Point  to open the New CAD Point dialog. See “Input 
Point” on page 1055 of the Reference Manual.

2. Select Absolute Location and define the point’s position at (0,0) and click OK. This is the 
current point that serves as the Start Point for the first line of the plot plan. See “Point 
Tools” on page 1054 of the Reference Manual.

3. Select CAD> Lines> North Pointer , then click and drag to create a North Pointer. For 
more information on this tool, see “North Pointer” on page 931 of the Reference Manual.

4. Select CAD> Lines> Input Line  to open the New CAD Line dialog. Notice that the 
Start Point is at (0,0): the location of the Current CAD Point. See “Input Line” on page 
1059 of the Reference Manual.

5. Click the Num Style button and in the Number Style/Angle Style dialog:
• Select Decimal Feet for the Number Style;
• Select Quadrant Bearing for the Angle Style. See “Dialog Number/Angle Style 

Dialog” on page 126 of the Reference Manual.
6. Click OK to return to the New CAD Line dialog 
7. Select Relative to Start Point and check the box beside Polar.
8. Enter the length of the first side of your property boundary’s legal description in the 

Distance field, and the angle of that line in the Angle field. To enter an angle using 
Quadrant Bearings, type:

• The primary direction (N or S), followed by a space; then,
• The angle in degrees, minutes, and seconds with a space after each value; then,
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• The secondary direction (E or W).

9. Click Next and enter the Distance and Angle of the next property line. 
10. Continue until all property lines are entered, then click OK to close the New CAD Line 

dialog. The resulting polyline should be closed, with the end point of the last line the same 
as the start point of the first.

To correct an error
1. If a line is entered incorrectly, click OK to close the New CAD Line dialog. 

2. Select Edit> Edit Behaviors> Edit Object Parts  to edit individual line segments 
within a polyline.

3. Click on the incorrect line to select it, then click Delete .

4. Click the Edit Object Parts  toggle button again to turn it off.

5. Place a CAD point at the end of the last correct line using the Place Point  tool to create 
a new current point.

6. Select CAD> Lines> Input Line  and continue entering data in the New CAD Line 
dialog.

Note: The angle of a given line can be described differently depending
on which end is used as the start point. Some property descriptions pro-
ceed in the same direction around the perimeter, whereas some do not.
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To create a curved property line 

1. Click a property line to select it, then click the Change Line/Arc  edit button to turn 
this line into an arc.

2. If necessary, use the triangular Reshape edit handle to make the arc concave or convex.

3. Click the Open Object  edit button to open the Polyline Specification dialog.
4. On the Selected Arc panel, click the Lock Chord radio button, then specify the length of 

the Radius and click OK. 

To display line length, bearing and radius

1. Select Edit> Default Settings .
2. In the Default Settings dialog, select CAD and click the Edit button.
3. In the CAD Defaults dialog, check Display Line Angle as Quadrant Bearing.
4. Click OK, then click Done to close the Default Settings dialog, as well. 

5. Click the plot plan polyline to select it, then click the Open Object  edit button. 
6. On the Line Style panel of the Polyline Specification dialog, check Show Length, Show 

Angle, and All Angles. 

A curved property line can also be created by entering data in the
New Arc dialog. See “Input Arc” on page 1069 of the Reference

Manual.
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To create setback lines

1. Select Edit> Preferences , and on the Behaviors panel of the Preferences dialog, 
select the Concentric Edit Mode. See “Behaviors Panel” on page 111 of the Reference 
Manual.

2. In the Jump field, type in the required setback distance, such as 10’, and click OK.

3. Click the plot plan polyline to select it, then click the Copy/Paste  edit button. 
4. Place your cursor over a corner edit handle, then click and drag towards the center of the 

polyline. When a second, inner polyline appears, release the mouse.

5. Select the inner polyline and click the Open Object  edit button to open the Polyline 
Specification dialog.

6. On the Line Style panel, select a dashed line style from the drop-down list, uncheck Show 
Length and Show Angle, then click OK.

7. When you have finished creating your concentric copy, select Edit> Edit Behaviors> 
Default  to restore the default edit behavior.

To place the setback polyline on a new layer

1. Select Tools> Layer Settings> Display Options  to open the Layer Display Options 
dialog.

2. Click the New button at the bottom of the dialog to open the New Layer Name dialog. 
Type a short, descriptive name such as "Lot Line Info", then click OK. 

3. Click OK to close the Layer Display Options dialog.
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4. In floor plan view, select the setback line and click the Open Object  edit button.
5. On the Line Style panel of the Polyline Specification dialog, click the Layer drop-down 

list and select the new layer you just created, then click OK.

To add a Plan Footprint to your Plot Plan

1. Select CAD> Plan Footprint . In the Plan Footprint dialog, a drop-down list allows 
you to select the Floor you want to create your plan footprint from.

2. Select a floor, then click OK to create a CAD object representing the building footprint in 
the CAD Detail window. See “Plan Footprint” on page 1099 of the Reference Manual.

3. You can control what information displays in the Plan Footprint selecting it and clicking 

the Open Object  edit button. On the General panel:

• Uncheck both Use Current Layer Set to Display and Display Plan Details; 
• Check the box beside Display Footprint Polyline.

4. On the Fill Style panel, select Angle Hatch from the drop down menu, and set the spacing 
to 15", then click OK to apply the changes.
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5. The Plan Footprint can be moved into place on the Plot Plan using its edit handles or edit 
tools.

To convert to a terrain perimeter

In order to create a terrain perimeter out of your plot plan, it must be copied from the CAD 
Detail in to your floor plan view.

1. Using the Select Objects  tool, click on the CAD polyline that forms the perimeter of 

your plot plan in the CAD Detail window and select Edit> Copy .
2. Next, click the window tab associated with the floor plan view to activate it, and go to 

Floor 1.

3. Select Edit> Paste> Paste  then click in the drawing area to place a copy of the 
polyline.

4. Select the newly pasted plot plan polyline and click the Convert Polyline  edit button. 
See “Convert Polyline” on page 237 of the Reference Manual.

5. In the Convert Polyline dialog, select Convert To: Terrain Perimeter, then click OK.

6. Make any needed changes in the Terrain Specification dialog and click OK. See “Terrain 
Specification Dialog” on page 725 of the Reference Manual.

If Terrain Perimeter is greyed out as an option, then a Terrain
Perimeter already exists in your floor plan which you will need to

locate and delete before you can convert the polyline.
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7. To increase the size of the text displayed along the Terrain Perimeter polyline, select 

Tools> Layer Settings> Display Options .
8. In the Layer Display Options dialog, scroll down to the Terrain Perimeter layer, and use 

the drop down menu to change the Text Style from the default to the Plot Plan Text Style 
and click OK.

To accurately position a building

1. Select CAD> Point> Place Point , and then click at a reference point along the 
perimeter of the building, such as at a corner. 

2. Select CAD> Points> Input Point  to open the New CAD Point dialog.
• Select Relative to Current Point;
• Using the X Position and Y Position fields, specify the distance that a known point on 

the property line should be from the Current CAD Point on the building perimeter. 
Unless you want to specify the location in distance and bearing, Polar (CCW from 
horz) should remain unchecked.

• Unless you want to specify the location in distance and bearing, Polar (CCW from 
horz) should remain unchecked.

3. When you click OK, a point is created at the specified location. Use this point as a 
reference to accurately position the Terrain Perimeter polyline. 


